Incident

MyHS is experiencing connection issues

Closed | Jan 31, 2020 | 20:05 GMT-05:00

Issue has been resolved and MyHS is operating normally.

Resolved | Jan 31, 2020 | 13:59 GMT-05:00

We are looking into connection issues with MyHS and are investigating.

Status Page powered by Admin Labs