Incident

IFTTT: Connection Issues

Monitoring | Jan 03, 2019 | 16:16 GMT-05:00

IFTTT: We are working on fixing known connection issues.

Investigating | Jan 03, 2019 | 14:47 GMT-05:00

We are working on fixing known connection issues.